The site you requested may not be relevant in your area.

Wednesday, August 8, 2018

Urgent security update required for your MobileMerchant app

As your payment provider we are committed to ensuring that our customers comply with industry security requirements for the processing of all types of card transactions.  We want to let you know about a critical update for your MobileMerchant app.

What is changing?

MobileMerchant has, for some years, used Security Certificates from Thawte to secure payment transactions. In 2017 Symantec’s Website Security business, which includes Thawte and GlobalSign, was sold to DigiCert. As part of the acquisition, the Thawte Certificate Authority certificates are being retired and Security Certificates from Thawte will no longer be trusted.

 

MobileMerchant is therefore switching to new Security Certificates from DigiCert on 28th August 2018. 

What does this mean for you?

If you are using a mobile phone or tablet running Android you should update the MobileMerchant app at the earliest opportunity to ensure you are not impacted

after 28th August 2018.

 

Support of the new Security Certificates from DigiCert is dependent on the mobile phone or tablet upon which you use the MobileMerchant app. 

What do you need to do?

We encourage you to perform this update as soon as possible, well in advance of the deadline of 28th August 2018, to minimise any impact on your business.

Get it on Google Play

A summary of the impact by operating system is shown below:

 

High impact: update required

Android (versions 4.x and earlier):

The new Security Certificates from DigiCert may not be supported and updating the MobileMerchant app is required to ensure continued use of MobileMerchant after 28th August 2018.

 

Low impact: update recommended

Android (versions 5.x and later)

The new Security Certificates from DigiCert are supported but updating the MobileMerchant app is recommended to ensure continued use of MobileMerchant after 28th August 2018.

 

No impact: no action is required

iOS (all versions)

The new Security Certificates from DigiCert are supported and no action is required.

 

The updated version of the MobileMerchant app (version 2.4.1) will automatically check for support of the new Security Certificates from DigiCert when the app is first launched.

 

If the Security Certificates are not supported, the app will install the Security Certificates and guide you through any further actions required.

What happens if you don’t update the MobileMerchant app

If the new Security Certificates from DigiCert are not installed on the mobile phone or tablet upon which you use the MobileMerchant app, then you will not be able to process transactions on or after 28th August 2018.

Here to help

If you receive warning messages after updating the MobileMerchant App for Android, or if you experience any issue completing transactions on or after 28th August 2018, please contact the technical support team:

 

mobile.merchant@elavon.com

 

0345 600 1401

Back To Latest News

Leaving?

By selecting "Continue," you will leave Elavon and enter a third party Web site. Elavon is not responsible for the content of, or products and services provided by   , nor does it guarantee the system availability or accuracy of information contained in the site. This Web site is not controlled by Elavon. Please note that the third party site may have privacy and information security policies that differ from those of Elavon.